Attempting to Implement "Hello World" example in VSCode

Hello everyone, I hope you are all doing well.

I am attempting to implement the weekly tech assignment regarding the “Hello World” example while using the CLI and Emulator. I downloaded VSCode and followed the instructions on how to get the vscode extension as well. I have this code:
Screen Shot 2020-07-07 at 4.14.02 PM
Screen Shot 2020-07-07 at 4.14.08 PM

I ran flow emulator start --init inside my HelloWorldFlow directory as well and it gave me the flow.json file. Now, when I do Shift + Command + P (for mac) and type run emulator, it gives me the terminal and everything, but I get this error when trying to run the transaction:
Screen Shot 2020-07-07 at 4.16.23 PM
Note: I get the exact same error code when trying to switch accounts and deploy the contract to a new account.
Any thoughts? Thanks a bunch! :slight_smile:

1 Like

@jacobtucker we have identified the cause, we will be sharing the fix for that error soon

2 Likes

@jacobtucker We forgot to include this in the vscode instructions, but the first account is reserved for the service account, which is a special account in Flow. So please do not try to deploy your code to that account or it will break the emulator. You’ll need to restart the emulator and deploy to the 2nd, 3rd… accounts.

We recognize this was a mistake and we’re fixing the extension to not show the service account. I’ll also update the instructions to point out this discrepancy in the meantime

3 Likes

Hello @jacobtucker, where can I find the weekly tech assignments and sessions. Thanks.

@kayherv you can find all information about the OWB course in this page: https://forum.onflow.org/c/open-world-builders/6
Check out the page titled " OWB - Recorded Sessions Archive" to find the recordings

1 Like

Thank you @flowjosh .

Hi, I tried to deploy hello.cdc contract with non service account, but getting the following message.

[Error - 12:29:59] Request workspace/executeCommand failed.
  Message: client: rpc error: code = NotFound desc = could not find account with address 179b6b1cb6755e31
  Code: -32603 

@makoto Could you try, running the stop emulator command, the restart language server command, and the run emulator command, in that order, to restart the emulator. Then make sure you see in the output window that the initial accounts are being created correctly. Then try again after that.

1 Like

Has this been taken down or do I just not have access to it yet? I’m trying to learn how to install the cadence extension for VScode so that I can start learning how to build some tools for Flow.