Gas limit is not in the acceptable range when creating account on testnet

When I try to create an account on testate using this command:

flow accounts create --network testnet --signer testnet-account --key 9d3d48ae994dc34681f3e805d48928c5da3c8985c592a243b8e84e42fa1d4a5ab3d3e21132964a32da8c9665bf2c46854a21b76eddc577b423ec58b80ab229a0

I got this error:

Transaction ID: a5220ed84ab174d5b476fece28bb0a5a80db6e165bd09db62b71293ef7b6fa84
:x: Invalid argument: invalid transaction: transaction gas limit (0) is not in the acceptable range (min: 1, max: 9999)

How can I setup gas limit?

Any luck? I am getting the same.
Not happening running against local.
In truffle.js, there is a gas parameter to specify this. Was hoping flow.json to have the same. does specify a --gas option, but I dont know where to stick it really.

still no luck. other ppl met the same as well.

I think it could be closed due to Add Gas Limit Default by sideninja · Pull Request #374 · onflow/flow-cli · GitHub, I have it worked with an updated flow-cli.

Yup. Its fixed :slight_smile: