Getting Ghosted by the Flow Testnet Faucet

As of 3/10/21, I’ve been getting ghosted by the Flow Testnet Faucet. I probably submitted to the Testnet Faucet around a dozen times. I tried all sorts of weird ways to format the public key. I’ve tried a couple of different emails. I haven’t gotten anything back. If I am lucky, it’s only because Flow has just become so popular that the servers are backlogged, in which case it’ll resolve itself by tomorrow (hopefully).

Does anybody have any knowledge of what might be causing this?

Ah, so sorry to ghost you! :slightly_frowning_face:

Our email service stopped working recently and unfortunately many emails never got delivered. I’m trying to see if we can re-deliver them.

However, we’ve actually been working on a new email-less faucet. We released it a bit early to unblock everybody:

Give it a try!

1 Like

I’m on the Testnet Faucet, and the Create New Address is not creating a new address. It loads and when it’s done, that’s it… a blank address. I’ve entered my public address. I’ve tried it in two different browsers, Brave and Firefox.

P.S It’s my first testnet account. Am I doing something wrong?

I think the Testnet network is down
Service Unavailable
This faucet is currrently unavailable due to an ongoing issue on Flow Testnet.