Ledger Common Issues and Solutions

Please find below a collection of solutions and tips to address most common problems. In general, we noticed the majority of issues encountered by users when using Flow app on Ledger can be solved with below solutions.

Problem
For those of you experiencing connection errors on Windows 10, we recommend this short-term fix

Solution

  • In Chrome, Brave or other Chromium-based browsers, navigate to chrome://flags#new-usb-backend
  • Ensure that the Enable new USB backend flag is set to “Disabled”
  • Restart your browser and reconnect your Ledger device

“Disabled” was the default setting up until Chrome 87 (released a few weeks ago), which changed the default to “Enabled”. Normally we would not recommend adjusting browser feature flags, but we see this as an acceptable short-term solution until the Ledger team releases an official patch for Web USB.

Problem
Hi team Ive followed the instructions above and disabled the new usb backend flag but still im not receiving any instructions on my Ledger (or approval message not appearing on Ledger device or similar variations)
image

Solution
Make sure you have latest firmware and Flow app version on your Ledger device

  • latest firmware for ledger >= 1.6.1
  • latest Flow app >= 0.9.5
  • Flow app on Ledger open when visiting Flow Port

Problem
Nano X bluetooth mode issues with Windows 10

Solution
Try below steps that worked for many users

  • Make sure Ledger Live is closed
  • Turn bluetooth off on your computer, ensure Ledger is connected with USB
  • Reconnect your Ledger using a different USB port
  • Restart your computer (I promise this worked at least one person!)

If you encounter new issues and/or solutions not mentioned above, please feel free to add to this thread.

Hello. I followed these instruction on both Win10 and Mac machines and am unable to create an account. Any other things to try? This thread is a couple months old, so I hope so!

If you tried within the last 1-2 hours we were solving an issue with Flow Port so that might be the reason. Try again tomorrow and let us know if it will work. If not happy to assist with other options.

1 Like

Yah i haven’t been able to log in the last few hours. Worried the heck out of me.

But if flow port is down that would make sense.

It sees my account number and says retrieving, but never moves past that point.

I’m trying to create an account on port.flow, I can connect with my ledger then press create account button and get the message: “The account creation request is being processed.” then it just goes back to sign in/sign up screen, I’ve tried with Brave and Edge.