Issues after updating flow-cli version

I built some smart contracts and tested them using CLI in version 0.33.0
It was working wonderfully.
However, after updating it to v0.350 / 0.36.0, it is not working.
I can’t even deploy some contracts because of errors below:
image

    pub fun borrowNFT(id: UInt64): &NonFungibleToken.NFT {
            return &self.ownedNFTs[id] as &NonFungibleToken.NFT
    }
    pub fun borrowCardItem(id: UInt64): &CardItems.NFT? {
            if self.ownedNFTs[id] != nil {
                let ref = &self.ownedNFTs[id] as auth &NonFungibleToken.NFT
                return ref as! &CardItems.NFT
            } else {
                return nil
            }
     }

Those two functions caused such errors.
I referred to Kitty-items for those functions.
It would be great pleasure if you help me.
You can contact @Sols or @brnaldomesi on discord.
Best Regards
@Sols

This is related to Secure Cadence breaking changes, you should read about them.

I figured out the issues.
Thanks.